[Top] [All Lists]

R3000 code in 2.0.6

To: (Linux MIPS mailing list)
Subject: R3000 code in 2.0.6
From: (Paul Antoine)
Date: Sat, 7 Sep 1996 07:49:57 +1000 (EST)
Organization: Softway Pty Ltd

I've been trying to compile the 2.0.6 release, in preparation for getting
the DECstation code working again and have run into a snag.  I'm getting
the following errors:

mipsel-linux-gcc -D__KERNEL__ -I/usr/home/mips/linux-2.0.6/include -Wall 
-Wstrict-prototypes -O2 -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic 
-mcpu=r3000 -mips1  -c r3000.S -o r3000.o
r3000.S: Assembler messages:
r3000.S:78: Warning: .type pseudo-op used outside of .def/.endef; ignored
r3000.S:78: Error: Rest of line ignored. First ignored character is `h'.
r3000.S:140: Warning: Macro used $at after ".set noat"
r3000.S:142: Warning: Tried to set unrecognized symbol: push

r3000.S:142: Warning: Tried to set unrecognized symbol: pop

and so on.  Since the code in the lines mentioned above is identical to
the 1.3.62 version, I'm assuming that there are changes elsewhere in
the source tree that are broken.  Any hints?

Paul M. Antoine,                                        Net:
Softway Pty Ltd                                         WWW:
PO Box 305, Strawberry Hills, NSW 2012, Australia       Tel: +61 2 9698 2322
Level 2, 79 Myrtle St, Chippendale, NSW 2008, Australia Fax: +61 2 9699 9174

"It is the lack of acceptance of diversity which threatens to 
 destroy society, NOT the free expression of it." - Me.

<Prev in Thread] Current Thread [Next in Thread>