[Top] [All Lists]

Re: m700-10 success

Subject: Re: m700-10 success
From: (Linux Support)
Date: Fri, 10 May 1996 21:57:43 +0200 (MET DST)
In-reply-to: <> from "Tor Arntsen" at May 10, 96 01:06:31 pm
> On May 8,  5:27, Systemkennung Linux wrote:
> [I wrote:]
> >> So what I had to do to get up and running was to disable the part of the 
> >> code
> >> in 3c503.c (el2_probe) that probes for shared memory.  This is because the
> >> 3c503 code tries shared memory probing first before it falls back to ioport
> >> probing.  The code piece I'm talking about is the one that starts with
> >
> >This is a bit weired because the address the the readl() accesses should
> >be correctly mapped in the TLB.  Could you send me your crash messages,
> >please?
> Ok, rebuilt with original 3c503.c:
> Got dbe at ffffffff80093010.

Ouch, a data bus error.  This says that the kernel tries to access non-
existant memory but the motherboard refuses to serve such requests.

Could you send me the output of the disassembler of this kernel image?
(Don't disassemble arch/mips/boot/zImage which has only four symbols
left, instead use ./vmlinux)  About the following command should send me
what I need:

mipsel-linux-objdump -d --reloc --start-address=0x80092f00 \
    --stop-address=0x80093100 vmlinux

> Unable to handle kernel paging request at virtual address 00000000,   \
>       epc == 00000000

This one is bad; it look as if the kernel tried to restore a corrupted
stackframe and then jumped to address zero which is unmappped.  The
CPU then takes a double TLB exception and you get your message.  Pretty
impossible to say why exactly this happend, but probably because
due to the dbe exception the kernel tried to throw away process 0 ...

Happy hacking,


<Prev in Thread] Current Thread [Next in Thread>