[Top] [All Lists]

Re: Oily report

Subject: Re: Oily report
From: Ralf Baechle <>
Date: Mon, 16 Oct 1995 17:14:01 +0100 (MET)
In-reply-to: <> from "Stoned Elipot" at Oct 16, 95 01:17:32 pm

> Hi all, 
> well here is where we are, aka State of the art on Oily boxes (I
> guess):
> kernel 1.2.11 boots and mounts a root fs from a 1.44M floppy - yes
> Andy your floppy driver works out of the box on the Oily - Sonic
> ethernet chip probing seems ok (good MAC address reported). We had
> problem linking user binaries ('we' is - as Paolo was in Paris this
> week-end - Luc, Paolo and me :): when we use mipsel-linux-ld to link
> things like ash or ifconfig (yes we can dream;) we got an 'undefined
> reference to _main', but it's solved by putting a '_' in from of main in
> the source (you should have heard Paolo saying "PUT AN _ IN FRONT OF
> IT" ;) or more cleany using mipsel-linux-gcc to do the link (Ralf can
> you light our lantern, please ?) Well at last we got an OMAGIC
> executable but the kernel panic when we tried to launch it (both ash
> and ifconfig),... the ash compiled by Ralf works fine,... I need to
> take a closer look  at this... Anyway, we still got to find out a way
> to proprely (aka without the NMI stuff) discover of much RAM there is
> in a Oily box...

There are two versions of the compiler out there - the ancient one prefixes
symbols with an underscore curing compile. The new one doesn't.

Try the follwing to find about what you've installed:

Compile the following program:


with the command

  mipsel-linux-gcc -S file.c

If the resulting file.s now contains a symbol _foo you're running the old
version of the compiler and must update.  Or look at the symbols in your
libc.a. If they're all prefixed with an '_' it's outdated ...  Btw - 2.7.0
is the best version of GCC anyway ...

About the RAM - you might try the Pica code in Milo. Does it work for your

> One more word, I'm still confused by the kernel: each time I try to
> compile a kernel with the Oily '#ifdef' and 'switch' I had added
> (surely wrongly), it fails to boot, so for now I use a "standard" MIPS
> Magnum 4000 configuration !! 

Yes, it's a bit messy. I'm cleaning it up a bit in the floppydriver.


<Prev in Thread] Current Thread [Next in Thread>