MIPS SDE Installation

From LinuxMIPS
Revision as of 14:06, 23 July 2005 by Nigel (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

MIPS SDE Download and Install

The current SDE release is 6.02.03, and is based on GCC 3.4, but with many local bug fixes and improvements. Take care when upgrading from GCC 2.x or if downgrading from GCC 4.x, because there are issues of both source code and ABI compatibility.

The Linux/386 cross-compiler is available as a single file, in RPM format:

Linux/386 cross for little-endian target 
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6.02.03-1/mipsel-sdelinux-v6.02.03-1.i386.rpm
Linux/386 cross for big-endian target 
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/mips-sdelinux-v6.02.03-1.i386.rpm.

The Linux/MIPS native compiler is organised into separate RPM files, mirroring the RedHat 7.x toolchain organisation:

Native big-endian
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-binutils-v6.02.03-1.mips.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-c++-v6.02.03-1.mips.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-cpp-v6.02.03-1.mips.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-gcc-v6.02.03-1.mips.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-gdb-v6.02.03-1.mips.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-libgcc-v6.02.03-1.mips.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-libstdc++-v6.02.03-1.mips.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-libstdc++-devel-v6.02.03-1.mips.rpm
Native little-endian
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-binutils-v6.02.03-1.mipsel.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-c++-v6.02.03-1.mipsel.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-cpp-v6.02.03-1.mipsel.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-gcc-v6.02.03-1.mipsel.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-gdb-v6.02.03-1.mipsel.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-libgcc-v6.02.03-1.mipsel.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-libstdc++-v6.02.03-1.mipsel.rpm
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-libstdc++-devel-v6.02.03-1.mipsel.rpm
Native install script 
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/install-native.sh
Source package
ftp://ftp.mips.com/pub/tools/software/sde-for-linux/6,02.03-1/sdelinux-v6.02.03-1.src.rpm

To avoid conflicts when installing the native MIPS toolchain only, you need to uninstall the old compiler and its support packages. This is most easily done by running the install-native.sh shell script listed above, which must be in the same directory as the rpm files. It will allow you to save your old toolchain package first, in case you need to uninstall SDE and revert.

The cross toolchain is installed simply using the rpm command, for example:

# rpm -Uv mipsel-sdelinux-v6.02.03-1.i386.rpm

MTUK would like to hear how well it worked, so contact them on sde@mips.com.