19r

From LinuxMIPS
Revision as of 01:44, 4 August 2005 by Bhildred (Talk | contribs)

Jump to: navigation, search

It appears there is only one person working (slowly) on porting linux to this box. Not yet ready for a prealpha release.

Physical description (observed)

Picture for a moment a 19 1/2" monitor (viewable diagonal) sitting on a pivot stand that if you are observant you will notice is slightly thicker than usual, with a keyboard and mouse sitting in front of it. Beautiful isn't it?

If you wander around to the back you will notice a power cable going to the monitor and a cable going from the monitor to the swivel base. The power supply is in the monitor and in the swivel base is the computer. On the back of the base there is the afore mentioned video and power connection; keyboard, mouse, and auxilary ports; and a removible network card. My network card has a RJ-45 connector (10-base-T ethernet), an AUI connector (DB15 with the funky slide latch), and link and polarity LEDs.

Major chips

The processor is a LSI LR33000MC-33.

There is a NCD PN 4400006 which apears to be a bridge or multifinction chip.

The main chip on the network card apears to be an AMD 4100004.

The monitor program is on the network card.

These pictures are taken from a diffrent model but are unmistakably similar to the network card in my box with the exception of the tranciver, connectors and labels on the rom chips. Note that there are two rom chips per bank, and three banks. Hmx-network-controller-1.jpeg Hmx-network-controller-2.jpeg

Bootstrap

Your usual for Xterminals BOOTP, TFTP load of kernal image. havn't yet found a image with a valid checksum to test boot with. There are two eproms on the NIC that are in the first of three 16 bit banks. Decompiling is started, but this is my first mips project.

Other Isues

Wont't talk to my ethernet switch. add a hub, and it works fine. go fig.

Update

The network card that i have has an RJ45 connector and an aui connector. If a cable is plugged in to the RJ45 connector and directly into a switch, there are severe failures. from reading elseware this appears to be relaited to a link test conflicting with duplex negeoation. Another workaround is to use an external tranciever possably with a modified aui cable. I plugged a tranciever directly into the aui port (no cable used) and it will now talk to the switch without the aid of a hub. --Bhildred 02:44, 4 Aug 2005 (BST)

Port status

Summary: Slim to none. If you want to help email me at b h i l d r e d (at) p e a k p e a k . c o m. --Bhildred 16:24, 26 Jul 2005 (BST)