linux-mips
[Top] [All Lists]

Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" a

To: Deng-Cheng Zhu <dengcheng.zhu@imgtec.com>, David Daney <ddaney.cavm@gmail.com>
Subject: Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_"
From: Paolo Bonzini <pbonzini@redhat.com>
Date: Fri, 27 Jun 2014 16:27:52 +0200
Cc: gleb@kernel.org, kvm@vger.kernel.org, sanjayl@kymasys.com, james.hogan@imgtec.com, ralf@linux-mips.org, linux-mips@linux-mips.org
In-reply-to: <53ACA261.7040007@imgtec.com>
List-archive: <http://www.linux-mips.org/archives/linux-mips/>
List-help: <mailto:ecartis@linux-mips.org?Subject=help>
List-id: linux-mips <linux-mips.eddie.linux-mips.org>
List-owner: <mailto:ralf@linux-mips.org>
List-post: <mailto:linux-mips@linux-mips.org>
List-software: Ecartis version 1.0.0
List-subscribe: <mailto:ecartis@linux-mips.org?subject=subscribe%20linux-mips>
List-unsubscribe: <mailto:ecartis@linux-mips.org?subject=unsubscribe%20linux-mips>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1403809900-17454-1-git-send-email-dengcheng.zhu@imgtec.com> <1403809900-17454-6-git-send-email-dengcheng.zhu@imgtec.com> <53AC7466.6070401@gmail.com> <53AC7AAD.7010007@imgtec.com> <53AC96D7.8040208@gmail.com> <53ACA261.7040007@imgtec.com>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
Il 27/06/2014 00:44, Deng-Cheng Zhu ha scritto:


x86 calls these things irq.c and irq.h, perhaps that would be a little
better.

There's also include/linux/irq.h


Yes, I know.

I simply wanted to let you know that if arch/mips/kvm/interrupt.h and
include/linux/interrupt.h are consufing, then arch/x86/kvm/irq.h and
include/linux/irq.h the same -- not even a little better.

And one of them is included as <linux/irq.h>, the other as "irq.h". So there's no possibility of confusion.

"kvm_mips_" seems totally useless as a prefix. I'm ambivalent with respect to removing the "kvm_" prefix; I'll apply the patch.

Paolo

<Prev in Thread] Current Thread [Next in Thread>