linux-mips
[Top] [All Lists]

Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" a

To: Deng-Cheng Zhu <dengcheng.zhu@imgtec.com>
Subject: Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_"
From: David Daney <ddaney.cavm@gmail.com>
Date: Thu, 26 Jun 2014 14:55:35 -0700
Cc: pbonzini@redhat.com, gleb@kernel.org, kvm@vger.kernel.org, sanjayl@kymasys.com, james.hogan@imgtec.com, ralf@linux-mips.org, linux-mips@linux-mips.org
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=message-id:date:from:user-agent:mime-version:to:cc:subject :references:in-reply-to:content-type:content-transfer-encoding; bh=ouj4f8rEMURVsw11moyCkkyzks8qvJ0xW25TC4eGjns=; b=UwsJgYMkG8HMHd8NFLwOyOnseytvxROQSwSyzhfasrWdm5BPd26ZaCdJBenfeaDFdu pLqoVWzVqWjvp3ukl/OK4/urPyz/5IXWc8UTmc52+0Zsr1TgTj8ta9hxbuIC8NiwXsI5 XLA5f6O0cu3nB6pOMbARj/OWIt9rh+Mvkek+zRLRyfYccLJv6MDtPSZqKBBA06hSFr6E tSDLLxpqnkRSoTjvQLn1rmRR47uzt8rEb6fJzV5koaaYA0B0ggxNtFirRtBMeywtqJrW eVSVcKhOVDJIngIkNKSUoY5SAoQzkGaL6e11pnNNGguOEtL3H2w88ligT1R5bqiDQNW9 N6Zg==
In-reply-to: <53AC7AAD.7010007@imgtec.com>
List-archive: <http://www.linux-mips.org/archives/linux-mips/>
List-help: <mailto:ecartis@linux-mips.org?Subject=help>
List-id: linux-mips <linux-mips.eddie.linux-mips.org>
List-owner: <mailto:ralf@linux-mips.org>
List-post: <mailto:linux-mips@linux-mips.org>
List-software: Ecartis version 1.0.0
List-subscribe: <mailto:ecartis@linux-mips.org?subject=subscribe%20linux-mips>
List-unsubscribe: <mailto:ecartis@linux-mips.org?subject=unsubscribe%20linux-mips>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1403809900-17454-1-git-send-email-dengcheng.zhu@imgtec.com> <1403809900-17454-6-git-send-email-dengcheng.zhu@imgtec.com> <53AC7466.6070401@gmail.com> <53AC7AAD.7010007@imgtec.com>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130625 Thunderbird/17.0.7
On 06/26/2014 12:55 PM, Deng-Cheng Zhu wrote:
On 06/26/2014 12:28 PM, David Daney wrote:
On 06/26/2014 12:11 PM, Deng-Cheng Zhu wrote:
From: Deng-Cheng Zhu <dengcheng.zhu@imgtec.com>

Since all the files are in arch/mips/kvm/, there's no need of the
prefixes
"kvm_" and "kvm_mips_".


I don't like this change.

It will leads me to confuse arch/mips/kvm/interrupt.h with
include/linux/interrupt.h

We have <linux/interrupt.h> and "interrupt.h".


x86 calls these things irq.c and irq.h, perhaps that would be a little
better.

There's also include/linux/irq.h


Yes, I know.


There is precedence in x86 for some of the names though.

But really why churn up the code in the first place?  the kvm_mips
prefix does tell us exactly what we are dealing with.

That's why people created the arch/mips/kvm directory, isn't it?

No. Segregating things into directories keeps code related to one functional area together.

File names are different.  They should carry as much meaning as possible.

For examples of this look at some of these directories:

drivers/net/ethernet/intel/ixgb
drivers/i2c/busses

It is not bad to have a filename prefix related to the function of the files.




Deng-Cheng





<Prev in Thread] Current Thread [Next in Thread>