[Top] [All Lists]

Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" a

To: David Daney <>
Subject: Re: [PATCH v4 5/7] MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_"
From: Deng-Cheng Zhu <>
Date: Thu, 26 Jun 2014 12:55:25 -0700
Cc: <>, <>, <>, <>, <>, <>, <>
In-reply-to: <>
List-archive: <>
List-help: <>
List-id: linux-mips <>
List-owner: <>
List-post: <>
List-software: Ecartis version 1.0.0
List-subscribe: <>
List-unsubscribe: <>
Original-recipient: rfc822;
References: <> <> <>
User-agent: Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Thunderbird/24.6.0
On 06/26/2014 12:28 PM, David Daney wrote:
On 06/26/2014 12:11 PM, Deng-Cheng Zhu wrote:
From: Deng-Cheng Zhu <>

Since all the files are in arch/mips/kvm/, there's no need of the prefixes
"kvm_" and "kvm_mips_".

I don't like this change.

It will leads me to confuse arch/mips/kvm/interrupt.h with include/linux/interrupt.h

We have <linux/interrupt.h> and "interrupt.h".

x86 calls these things irq.c and irq.h, perhaps that would be a little better.

There's also include/linux/irq.h

There is precedence in x86 for some of the names though.

But really why churn up the code in the first place? the kvm_mips prefix does tell us exactly what we are dealing with.

That's why people created the arch/mips/kvm directory, isn't it?


<Prev in Thread] Current Thread [Next in Thread>