linux-mips
[Top] [All Lists]

Re: select() to /dev/rtc0 to wait for clock tick timed out

To: john stultz <johnstul@us.ibm.com>
Subject: Re: select() to /dev/rtc0 to wait for clock tick timed out
From: Xiangfu Liu <xiangfu@openmobilefree.net>
Date: Fri, 16 Mar 2012 16:53:58 +0800
Cc: Matt Turner <mattst88@gmail.com>, linux-mips@linux-mips.org, rtc-linux@googlegroups.com
In-reply-to: <4EFD76F9.50204@openmobilefree.net>
Organization: http://www.openmobilefree.net
References: <CAEdQ38HGfd9YWE+WLuirE4Km6UE6N26toTj=-1BuXAQUux6t5g@mail.gmail.com> <1313777242.2970.131.camel@work-vm> <CAEdQ38F4zi76ug+ABZPnPLcLvGfUFRhr6SKzYCN+24Otq+qAAQ@mail.gmail.com> <1313783990.2970.136.camel@work-vm> <4EFD76F9.50204@openmobilefree.net>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:10.0.2) Gecko/20120216 Thunderbird/10.0.2
Hi

After I update kernel to linux v3.2.1. the problem still there.
Please give me some advice, how to fix this issue?

Thanks

On 12/30/2011 04:31 PM, Xiangfu Liu wrote:
Hi John Stultz

I meet the same problem on MIPS jz4740, here is the step I try to find out the 
problem:

1. when I direct run 'hwclock' it will give
    "select() to /dev/rtc0 to wait for clock tick timed out"
    attachment 'hwclock.time.out' is the strace log

2. run 'rtctest' program. it works fine. the output is here[1]

3. after 'rtctest', run 'hwclock' again. then it works fine
    attachment 'hwclock.wors' is the strace log

without 'rtctest' run first. 'hwclock' never works.
the hwclock works fine in 2.6.27.6, failed under '3.0.0'

Please give me some tips how to fix this problem. shoule I modify the driver 
code
or is that relate to 'CONFIG_RTC_INTF_DEV_UIE_EMUL'?

thanks in advance.
xiangfu


<Prev in Thread] Current Thread [Next in Thread>