linux-mips
[Top] [All Lists]

Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

To: Sangwook Lee <sangwook.lee@linaro.org>
Subject: Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h
From: Kalle Valo <kvalo@adurom.com>
Date: Tue, 15 Nov 2011 18:37:08 +0200
Cc: linux-kernel@vger.kernel.org, linux-mips@linux-mips.org, linux-wireless@vger.kernel.org, ath9k-devel@lists.ath9k.org, ralf@linux-mips.org, juhosg@openwrt.org, rodrigue@qca.qualcomm.com, linville@tuxdriver.com, rmanohar@qca.qualcomm.com, patches@linaro.org
In-reply-to: <1321356224-5053-1-git-send-email-sangwook.lee@linaro.org>
References: <1321356224-5053-1-git-send-email-sangwook.lee@linaro.org>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.23) Gecko/20110922 Thunderbird/3.1.15
Hi Sangwook,

On 11/15/2011 01:23 PM, Sangwook Lee wrote:
> The patch series proposes to rename ath9k_platform.h to "ath_platform.h
> This header file handles platform data used only for ath9k,
> but it can used by ath6k as well. We can take "wl12xx.h" as
> as a example. Please let us change this file name so that
> other Atheors WLANs use this file for their own platform data

ath9k and ath6kl are very different devices, I'm not sure if sharing a
platfrom struct between the two is really a good idea. Most likely there
is very little the two drivers can share. What are your plans here?

I myself was thinking that we would have include/linux/ath6kl.h
dedicated just for ath6kl. That would makes things simpler.

Kalle

<Prev in Thread] Current Thread [Next in Thread>