linux-mips
[Top] [All Lists]

RE: Mega rename of device tree routines from of_*() to dt_*()

To: David Daney <ddaney@caviumnetworks.com>
Subject: RE: Mega rename of device tree routines from of_*() to dt_*()
From: Stephen Neuendorffer <stephen.neuendorffer@xilinx.com>
Date: Wed, 24 Nov 2010 10:32:11 -0800
Cc: <michael@ellerman.id.au>, LKML <linux-kernel@vger.kernel.org>, linux-mips <linux-mips@linux-mips.org>, <microblaze-uclinux@itee.uq.edu.au>, <devicetree-discuss@lists.ozlabs.org>, linuxppc-dev list <linuxppc-dev@ozlabs.org>, <sparclinux@vger.kernel.org>
In-reply-to: <4CED48CE.5060300@caviumnetworks.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1290607413.12457.44.camel@concordia> <fa44e045-9600-4c46-939a-af246afab4f6@VA3EHSMHS019.ehs.local> <4CED48CE.5060300@caviumnetworks.com>
Sender: linux-mips-bounce@linux-mips.org
Thread-index: AcuL+5MExKaPVux0RsiMeMP0dz+DbQACj7rQ
Thread-topic: Mega rename of device tree routines from of_*() to dt_*()

> -----Original Message-----
> From: David Daney [mailto:ddaney@caviumnetworks.com]
> Sent: Wednesday, November 24, 2010 9:18 AM
> To: Stephen Neuendorffer
> Cc: michael@ellerman.id.au; LKML; linux-mips; 
> microblaze-uclinux@itee.uq.edu.au; devicetree-
> discuss@lists.ozlabs.org; linuxppc-dev list; sparclinux@vger.kernel.org
> Subject: Re: Mega rename of device tree routines from of_*() to dt_*()
> 
> On 11/24/2010 09:02 AM, Stephen Neuendorffer wrote:
> >
> >
> >> -----Original Message-----
> >> From: linuxppc-dev-bounces+stephen=neuendorffer.name@lists.ozlabs.org 
> >> [mailto:linuxppc-dev-
> >> bounces+stephen=neuendorffer.name@lists.ozlabs.org] On Behalf Of Michael 
> >> Ellerman
> >> Sent: Wednesday, November 24, 2010 6:04 AM
> >> To: LKML
> >> Cc: linux-mips; microblaze-uclinux@itee.uq.edu.au; 
> >> devicetree-discuss@lists.ozlabs.org; linuxppc-
> dev
> >> list; sparclinux@vger.kernel.org
> >> Subject: RFC: Mega rename of device tree routines from of_*() to dt_*()
> >>
> >> Hi all,
> >>
> >> There were some murmurings on IRC last week about renaming the of_*()
> >> routines. I was procrastinating at the time and said I'd have a look at
> >> it, so here I am.
> >>
> >> The thinking is that on many platforms that use the of_() routines
> >> OpenFirmware is not involved at all, this is true even on many powerpc
> >> platforms. Also for folks who don't know the OpenFirmware connection it
> >> reads as "of", as in "a can of worms".
> >>
> >> Personally I'm a bit ambivalent about it, the OF name is a bit wrong so
> >> it would be nice to get rid of, but it's a lot of churn.
> >>
> >> So I'm hoping people with either say "YES this is a great idea", or "NO
> >> this is stupid".
> >
> > Personally, I think it's a great idea, if only because I stared long and 
> > hard
> > at the code once upon a time trying to figure out what is really OF-related
> > and what isn't.  It's somewhat clearer now that drivers/of has been factored
> > out (although, shouldn't it be drivers/dt???)
> >
> > That said, it *is* alot of code churn.  If it's going to be done, I think 
> > it should be
> > done in concert with fixing a bunch of the function names which don't 
> > really follow any
> > sane naming convention, so that the backporting discontinuity only happens 
> > once.
> >
> 
> Oh, you mean things like:
> 
> of_{,un}register_platform_driver vs. platform_driver_{,un}register
> 
> That one is particularly annoying to me.
> 
> David Daney

Actually, I was particularly thinking of drivers/of/fdt.c, which I was recently 
hacking around with,
but I'm sure there are others... :)

Steve

This email and any attachments are intended for the sole use of the named 
recipient(s) and contain(s) confidential information that may be proprietary, 
privileged or copyrighted under applicable law. If you are not the intended 
recipient, do not read, copy, or forward this email message or any attachments. 
Delete this email message and any attachments immediately.
<Prev in Thread] Current Thread [Next in Thread>