linux-mips
[Top] [All Lists]

Re: [PATCH v2] mips/alchemy: add basic support for the GPR board

To: Florian Fainelli <florian@openwrt.org>
Subject: Re: [PATCH v2] mips/alchemy: add basic support for the GPR board
From: Wolfgang Grandegger <wg@grandegger.com>
Date: Thu, 15 Jul 2010 11:04:39 +0200
Cc: linux-mips@linux-mips.org, Wolfgang Grandegger <wg@denx.de>
In-reply-to: <AANLkTindpsjxnTgpchvuqkxBqYg3NtsP39wXq61QRR-3@mail.gmail.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1279115243-11586-1-git-send-email-wg@grandegger.com> <AANLkTindpsjxnTgpchvuqkxBqYg3NtsP39wXq61QRR-3@mail.gmail.com>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100430 Fedora/3.0.4-2.fc12 Thunderbird/3.0.4
On 07/14/2010 08:40 PM, Florian Fainelli wrote:
> Hi Wolfgang,
> 
> 2010/7/14 Wolfgang Grandegger <wg@grandegger.com>:
>> From: Wolfgang Grandegger <wg@denx.de>
>>
>> This patch adds basic support for the General Purpose Router (GPR)
>> board from Trapeze ITS.
>>
>> Signed-off-by: Wolfgang Grandegger <wg@denx.de>
> [snip]
> 
>> +
>> +/*
>> + * LEDs
>> + */
>> +static struct gpio_led gpr_gpio_leds[] = {
>> +       {       /* green */
>> +               .name                   = "green",
>> +               .gpio                   = 4,
>> +               .active_low             = 1,
>> +               .default_trigger        = "none",
>> +       },
>> +       {       /* red */
>> +               .name                   = "red",
>> +               .gpio                   = 5,
>> +               .active_low             = 1,
>> +               .default_trigger        = "none",
>> +       }
>> +};
> 
> Should be "gpr:green" and "gpr:red" respectively to follow the Linux
> LEDs class naming conventions. The default trigger is superfluous,

Will be fixed.

> however it would make sense to have the green led be associated with
> the "default-on" trigger. Otherwise, it looks very good.

I just played with various default triggers. None of them is needed and
I will remove it. In the board setup code, the LEDs are toggled and
therefore I do not want to define a "default-on".

Thanks,

Wolfgang.

<Prev in Thread] Current Thread [Next in Thread>