linux-mips
[Top] [All Lists]

Re: [PATCH v2] mips/alchemy: add basic support for the GPR board

To: Wolfgang Grandegger <wg@grandegger.com>
Subject: Re: [PATCH v2] mips/alchemy: add basic support for the GPR board
From: Florian Fainelli <florian@openwrt.org>
Date: Wed, 14 Jul 2010 20:40:27 +0200
Cc: linux-mips@linux-mips.org, Wolfgang Grandegger <wg@denx.de>
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:sender:received :in-reply-to:references:date:x-google-sender-auth:message-id:subject :from:to:cc:content-type:content-transfer-encoding; bh=XjV6m97nqnD4CfXwvimvLLVM8J0z+xObUZ8n1hX+CzM=; b=LB0DKO2LN6ypOoMRoSIueiXw/ucVslZvh9JOn0Bf6zEF6qwy9DoaGVgoUc6GJsTe// rUy6xkSUkrOLGitOZJ/IQVHSbWrpjXF1Vx5B6IJ4Wn9tkodUcH18Kx5KUttdpq6Y72Hc POXS1oupQbSBzhMUkapDIcbiwbGwbPbdOJm9M=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:sender:in-reply-to:references:date :x-google-sender-auth:message-id:subject:from:to:cc:content-type :content-transfer-encoding; b=Aq3ii5Uklo1fjVsHxtN1Gx0tUz4PdGPnM8tTcXh2QtgTSJkPcwq4gM+rkyeN7xpBUy pHsjLaj8xmbbq/DUt0ItouFhHgqSaqKYuKRBPvdAWGbyHXATlyp4tv0h/ycuiVX+jiD1 81gQ2ajhjx8AHqoG3Lisrng6NPEETajMsVtYw=
In-reply-to: <1279115243-11586-1-git-send-email-wg@grandegger.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1279115243-11586-1-git-send-email-wg@grandegger.com>
Sender: linux-mips-bounce@linux-mips.org
Hi Wolfgang,

2010/7/14 Wolfgang Grandegger <wg@grandegger.com>:
> From: Wolfgang Grandegger <wg@denx.de>
>
> This patch adds basic support for the General Purpose Router (GPR)
> board from Trapeze ITS.
>
> Signed-off-by: Wolfgang Grandegger <wg@denx.de>
[snip]

> +
> +/*
> + * LEDs
> + */
> +static struct gpio_led gpr_gpio_leds[] = {
> +       {       /* green */
> +               .name                   = "green",
> +               .gpio                   = 4,
> +               .active_low             = 1,
> +               .default_trigger        = "none",
> +       },
> +       {       /* red */
> +               .name                   = "red",
> +               .gpio                   = 5,
> +               .active_low             = 1,
> +               .default_trigger        = "none",
> +       }
> +};

Should be "gpr:green" and "gpr:red" respectively to follow the Linux
LEDs class naming conventions. The default trigger is superfluous,
however it would make sense to have the green led be associated with
the "default-on" trigger. Otherwise, it looks very good.
--
Florian
<Prev in Thread] Current Thread [Next in Thread>