linux-mips
[Top] [All Lists]

Re: [PATCH] MIPS: Use compat version for n32 sys_ppoll.

To: David Daney <ddaney@caviumnetworks.com>
Subject: Re: [PATCH] MIPS: Use compat version for n32 sys_ppoll.
From: Ralf Baechle <ralf@linux-mips.org>
Date: Tue, 11 May 2010 01:31:51 +0100
Cc: linux-mips@linux-mips.org, Chandrakala Chavva <cchavva@caviumnetworks.com>
In-reply-to: <1273536714-27535-1-git-send-email-ddaney@caviumnetworks.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1273536714-27535-1-git-send-email-ddaney@caviumnetworks.com>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.5.20 (2009-08-17)
On Mon, May 10, 2010 at 05:11:54PM -0700, David Daney wrote:

> From: Chandrakala Chavva <cchavva@caviumnetworks.com>
> 
> The sys_ppoll() takes struct 'struct timespec'. This is different
> for n32 and n64 abi. Use the compat version to do the proper conversions.
> 
> Signed-off-by: David Daney <ddaney@caviumnetworks.com>

Sigh, this sort of fix has a long tradition.  I'm glad we're maintaining
it ;-)  Patch applied.

Thanks,

  Ralf

<Prev in Thread] Current Thread [Next in Thread>