linux-mips
[Top] [All Lists]

Re: [loongson-dev] Re: a pre-release of merging loongson patchs to linux

To: loongson-dev@googlegroups.com
Subject: Re: [loongson-dev] Re: a pre-release of merging loongson patchs to linux-2.6.29.1
From: Erwan Lerale <erwan@thiscow.com>
Date: Fri, 24 Apr 2009 08:46:57 +0200
Cc: yanh@lemote.com, zhangfx@lemote.com, penglj@lemote.com, huhb@lemote.com, taohl@lemote.com, linux-mips@linux-mips.org, Ralf Baechle <ralf@linux-mips.org>
In-reply-to: <1240535343.25824.14.camel@falcon>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1240501332.28136.24.camel@falcon> <49F0AFA3.6080408@thiscow.com> <1240535343.25824.14.camel@falcon>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Thunderbird 2.0.0.21 (X11/20090409)
Wu Zhangjin a écrit :
I can not compile it :

  CC      arch/mips/loongson/common/bonito-irq.o
  CC      arch/mips/loongson/common/mem.o
  CC      arch/mips/loongson/common/dbg_io.o
cc1: warnings being treated as errors
arch/mips/loongson/common/dbg_io.c: In function �prom_printf
arch/mips/loongson/common/dbg_io.c:178: error: the frame size of 1040
bytes is larger than 1024 bytes
make[1]: *** [arch/mips/loongson/common/dbg_io.o] Error 1
make: *** [arch/mips/loongson/common] Error 2


which gcc compiler do you use? gcc 4.4? i just try to compile it in gcc
4.4, get the same error. but i only test it in gcc 4.3(cross-compiler)
before, only a few "trivial" warnings.

a new branch for gcc 4.4 will be created as quickly as i can.


Yeap :

gcc version 4.4.0-pre9999 built 20090212 (Gentoo SVN ebuild) rev. 144120 ()



really thanks for your encouragement, welcome to take part in, lots of
source code lines need to be cleaned up.


I would be happy to help with the code but my C skills are need the "hello world" stuff :)
I can help with testing and writing documentations.

Cheers
Erwan

<Prev in Thread] Current Thread [Next in Thread>