linux-mips
[Top] [All Lists]

HIGHMEM and 2.6.28

To: "linux-mips@linux-mips.org" <linux-mips@linux-mips.org>
Subject: HIGHMEM and 2.6.28
From: "Jon Fraser" <jfraser@broadcom.com>
Date: Thu, 02 Apr 2009 20:30:46 -0400
Organization: Broadcom
Original-recipient: rfc822;linux-mips@linux-mips.org
Reply-to: jfraser@broadcom.com
Sender: linux-mips-bounce@linux-mips.org
Has anybody been able to get HIGHMEM to work on 2.6.28
with an r4k style processor?

We have it working on 2.6.24 on a mips r24k.  We even have it working
with discontiguous memory and cache aliasing.  I ported our changes
to 2.6.28, but no joy.  I switched to a smaller cache to avoid cache
aliasing, and changed to a flat memory model to eliminate the
discontiguous memory code, but still no joy.  

We're using 2.6.28.9

Thanks,
Jon Fraser
Broadcom




<Prev in Thread] Current Thread [Next in Thread>
  • HIGHMEM and 2.6.28, Jon Fraser <=