linux-mips
[Top] [All Lists]

Re: BigSur: garbled characters during boot

To: Martin Michlmayr <tbm@cyrius.com>
Subject: Re: BigSur: garbled characters during boot
From: "Maciej W. Rozycki" <macro@linux-mips.org>
Date: Mon, 26 Nov 2007 11:34:50 +0000 (GMT)
Cc: linux-mips@linux-mips.org, manoj.ekbote@broadcom.com, mark.e.mason@broadcom.com
In-reply-to: <20071125134333.GO20922@deprecation.cyrius.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <20071125124842.GA32479@deprecation.cyrius.com> <20071125.222803.25909189.anemo@mba.ocn.ne.jp> <20071125134333.GO20922@deprecation.cyrius.com>
Sender: linux-mips-bounce@linux-mips.org
On Sun, 25 Nov 2007, Martin Michlmayr wrote:

> > IIRC Maciej have tried to fix this issue a while ago on LKML.
> 
> Right, I think I remember that discussion.  Did anything come out
> of it?

 The exact mess encountered is specific to the chip/board used.  I haven't 
seen too much of clutter on my SWARM, so I just disregarded the issue.  
If this is found problematic, I may have a look at the driver to see if 
anything can be done.  At least CFE sources are available, so if it turns 
out to be an issue there, it can be fixed too.  All the relevant registers 
in the DUART are r/w, so the state can easily be examined and preserved if 
need be.

 But please feel free to complain to the author of the change -- I am not 
sure if the amount of breakage throughout systems is justified by the gain 
from the additional message.  And there may be a way to implement it in a 
less intrusive way.

  Maciej

<Prev in Thread] Current Thread [Next in Thread>