linux-mips
[Top] [All Lists]

Re: [PATCH] Introduce __fill_user() and kill __bzero() [take #2]

To: Franck Bui-Huu <vagabon.xyz@gmail.com>
Subject: Re: [PATCH] Introduce __fill_user() and kill __bzero() [take #2]
From: Geert Uytterhoeven <geert@linux-m68k.org>
Date: Thu, 15 Nov 2007 23:09:01 +0100 (CET)
Cc: Ralf Baechle <ralf@linux-mips.org>, Thiemo Seufer <ths@networkno.de>, linux-mips <linux-mips@linux-mips.org>
In-reply-to: <473CB727.8010106@gmail.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <473C720B.7000100@gmail.com> <Pine.LNX.4.64.0711151744580.31039@anakin> <473CB727.8010106@gmail.com>
Sender: linux-mips-bounce@linux-mips.org
On Thu, 15 Nov 2007, Franck Bui-Huu wrote:
> Geert Uytterhoeven wrote:
> > On Thu, 15 Nov 2007, Franck Bui-Huu wrote:
> >>  I put the out of line version of memset in kernel/mips_ksym.c. I
> >>  haven't found a better place. But if you really think we should
> >>  create a lib/memset.c and rename lib/memset.S into lib/fill_user.S, I
> >>  can change it.
> > 
> > kernel/mips_ksym.c is not a good place.
> 
> Sigh... thanks for spotting this.
> 
> So since I've no idea where I could put this function I'll follow
> Thiemo's suggestion but instead of calling the new file lib/memset.c,
> I'll use lib/string.c since we could move or implement other stuffs in
> it.
> 
> Is it ok ?

lib/string.c sounds fine to me. That's where m68k and s390 implement it
as well.

Gr{oetje,eeting}s,

                                                Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                                            -- Linus Torvalds

<Prev in Thread] Current Thread [Next in Thread>