linux-mips
[Top] [All Lists]

Qemu and Linux 2.4

To: qemu-devel@nongnu.org, linux-mips@linux-mips.org
Subject: Qemu and Linux 2.4
From: Vlad Lungu <vlad@comsys.ro>
Date: Tue, 11 Sep 2007 15:31:31 +0300
Original-recipient: rfc822;linux-mips@linux-mips.org
Sender: linux-mips-bounce@linux-mips.org
User-agent: Thunderbird 1.5.0.9 (Windows/20061207)
I know some of you will laugh, but:

- QEMU malta emulation is not really complete, to put it mildly
- the QEMU target is available only for Linux 2.6
- despite popular opinion, 2.4 ain't dead yet, at least in the embedded market


I have a port of the QEMU target for Linux 2.4.34.4 (latest 2.4 kernel on linux-mips.org), with NE2000 card working (in both BE and LE modes).
Still rough at the edges, but it works on stock qemu-0.9.0 with -M mips.

If anyone is interested, I can send the patch by e-mail. I have no idea if I can post attachments to the list(s), that's why it's not attached.

Vlad

<Prev in Thread] Current Thread [Next in Thread>