linux-mips
[Top] [All Lists]

Re: RFC: drop support for gcc < 4.0

To: "Chris Wedgwood" <cw@f00f.org>
Subject: Re: RFC: drop support for gcc < 4.0
From: "Glauber de Oliveira Costa" <glommer@gmail.com>
Date: Tue, 21 Aug 2007 17:41:04 -0300
Cc: "Adrian Bunk" <bunk@kernel.org>, "Randy Dunlap" <randy.dunlap@oracle.com>, "Linus Torvalds" <torvalds@linux-foundation.org>, "Andrew Morton" <akpm@linux-foundation.org>, "Jarek Poplawski" <jarkao2@o2.pl>, linux-kernel@vger.kernel.org, linux-arch@vger.kernel.org, linux-mips@linux-mips.org
Dkim-signature: a=rsa-sha1; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=kJ8Vu64KKjNiL5xP+IVsAetxZSGI7JxOdZNafXK/+lrMWqUzAxEihpXGu4PczyPKrxuy+oNGBx18Jpf2jbzemVBzp4/HrMDpH7S7WW9g9uKFTpIeqwXx/AW3/41YIsDwcy2HkcnCWHx4aIupk2Rpc1DobwkAe9hjAIJonJFDVBE=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=cN4tXoYMxt/nrUp0m8GRowxotWIePfjMMlyUXlSbA+oCc1bAnsrAPg191j7/xlp63WkmmT4ozcxwCUqsoSPewHIxmCy3GrPYXtIBuP3NwfUZnU2dFopbUyY+WfXhUtyRqfywpVBMpwhGD9/XpDuRjCQzWXtYb9u9IDJ7vrNpstA=
In-reply-to: <20070821182505.GA20968@puku.stupidest.org>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <20070821132038.GA22254@ff.dom.local> <20070821093103.3c097d4a.randy.dunlap@oracle.com> <20070821173550.GC30705@stusta.de> <20070821182505.GA20968@puku.stupidest.org>
Sender: linux-mips-bounce@linux-mips.org
On 8/21/07, Chris Wedgwood <cw@f00f.org> wrote:
> On Tue, Aug 21, 2007 at 07:35:50PM +0200, Adrian Bunk wrote:
>
> > Are there any architectures still requiring a gcc < 4.0 ?
>
> Yes, sadly in some places (embedded) there are people with older
> compiler who want newer kernels.

Last time I tried a mips build, it would fail the compile unless I was
using _exactly_ 3.4.4 (I didn't tried older versions, but did try
3.4.6, for ex.). So I also think the 3.4 series will still have to be
around for a while.

-- 
Glauber de Oliveira Costa.
"Free as in Freedom"
http://glommer.net

"The less confident you are, the more serious you have to act."

<Prev in Thread] Current Thread [Next in Thread>