linux-mips
[Top] [All Lists]

Re: [PATCH 4/5] Use -Werror on TX39/TX49 boards

To: Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH 4/5] Use -Werror on TX39/TX49 boards
From: Ralf Baechle <ralf@linux-mips.org>
Date: Fri, 3 Aug 2007 14:36:29 +0100
Cc: Atsushi Nemoto <anemo@mba.ocn.ne.jp>, linux-mips@linux-mips.org
In-reply-to: <20070803132550.GA21454@lst.de>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <20070802.233617.70476666.anemo@mba.ocn.ne.jp> <20070803132550.GA21454@lst.de>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.5.14 (2007-02-12)
On Fri, Aug 03, 2007 at 03:25:50PM +0200, Christoph Hellwig wrote:

> Please don't.  Adding -Werror is a complete pain in the ass for people
> using new compilers or when we get things like __deprecated or
> __warn_unused warnings from headers.  We've dropped it again from
> the various placed that had introduced this.

It seems to crank up the the pain level to the point where people upgrade
their code :-)

  Ralf

<Prev in Thread] Current Thread [Next in Thread>