linux-mips
[Top] [All Lists]

Building a cross kernel for the IP27/Origin System

To: linux-mips@linux-mips.org
Subject: Building a cross kernel for the IP27/Origin System
From: Claus Herrmann <claus.herrmann@cybits.de>
Date: Tue, 08 May 2007 17:02:50 +0200
Original-recipient: rfc822;linux-mips@linux-mips.org
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mozilla Thunderbird 1.0.7 (Windows/20050923)
Hi,

ich have a question regarding the crosscompiling for an Origin 2000. First of all i get this warning:

include/linux/mmzone.h:553:1: warning: "NODE_DATA" redefined
In file included from include/asm/mmzone.h:9,
                from include/asm-mips/mach-ip27/topology.h:5,
                from include/asm/topology.h:1,
                from include/linux/topology.h:34,
                from include/linux/mmzone.h:544,
                from include/linux/gfp.h:4,
                from include/linux/slab.h:14,
                from include/linux/percpu.h:5,
                from include/linux/rcupdate.h:41,
                from include/linux/pid.h:4,
                from include/linux/sched.h:72,
                from arch/mips/kernel/asm-offsets.c:13:
include/asm-mips/mach-ip27/mmzone.h:33:1: warning: this is the location of the 
previous definition

I fixed it by doing a #define and a #ifndef around the golbal NODE_DATA.
Now it compiles smoothly, but in the end I get this:

mips-linux-ld: Dwarf Error: found dwarf version '0', this reader only handles 
version 2 information.
mips-linux-ld: Dwarf Error: found dwarf version '0', this reader only handles 
version 2 information.
mips-linux-ld: Dwarf Error: found dwarf version '365', this reader only handles 
version 2 information.
mips-linux-ld: Dwarf Error: found dwarf version '22528', this reader only 
handles version 2 information.
arch/mips/mm/built-in.o: In function `mem_init':
: multiple definition of `mem_init'
mips-linux-ld: Dwarf Error: found dwarf version '0', this reader only handles 
version 2 information.
mips-linux-ld: Dwarf Error: found dwarf version '8704', this reader only 
handles version 2 information.
arch/mips/sgi-ip27/built-in.o:: first defined here
arch/mips/mm/built-in.o: In function `paging_init':
: multiple definition of `paging_init'
arch/mips/sgi-ip27/built-in.o:: first defined here
make: *** [.tmp_vmlinux1] Fehler 1

Any suggestions what i am doing wrong?
The toolchan i use is the one from MIPS SDE UK. I tried to build my own Toolchain, but the same error occur.

Brgds

Claus

<Prev in Thread] Current Thread [Next in Thread>