linux-mips
[Top] [All Lists]

Re: [PATCH]: Remove CONFIG_BUILD_ELF64 entirely

To: "Maciej W. Rozycki" <macro@linux-mips.org>
Subject: Re: [PATCH]: Remove CONFIG_BUILD_ELF64 entirely
From: Ralf Baechle <ralf@linux-mips.org>
Date: Mon, 26 Mar 2007 12:56:56 +0100
Cc: Thiemo Seufer <ths@networkno.de>, Kumba <kumba@gentoo.org>, Linux MIPS List <linux-mips@linux-mips.org>
In-reply-to: <Pine.LNX.4.64N.0703261234260.16083@blysk.ds.pg.gda.pl>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <4603DA74.70707@gentoo.org> <20070324.002440.93023010.anemo@mba.ocn.ne.jp> <46049BAD.1010705@gentoo.org> <20070324.234727.25910303.anemo@mba.ocn.ne.jp> <20070324231602.GP2311@networkno.de> <46062400.8080307@gentoo.org> <20070325144515.GB21439@networkno.de> <Pine.LNX.4.64N.0703261234260.16083@blysk.ds.pg.gda.pl>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.4.2.2i
On Mon, Mar 26, 2007 at 12:35:59PM +0100, Maciej W. Rozycki wrote:

> On Sun, 25 Mar 2007, Thiemo Seufer wrote:
> 
> > AFAICS this loses -mno-explicit-relocs completely, but it is needed for
> > all non-ckseg0 CONFIG_64BIT builds.
> 
>  Why?  I reckon GCC should support them just fine these days.

Please remember that we officially only require GCC 3.2 or newer.  3.2
turned out to be too broken to be supported for 64-bit builds but as long
as there is no significant problem I'd like to keep support for these
compiler antiques alive.

  Ralf

<Prev in Thread] Current Thread [Next in Thread>