[Top] [All Lists]

SGI Octane kernel patches fail

Subject: SGI Octane kernel patches fail
From: Jens Seidel <>
Date: Thu, 14 Dec 2006 21:35:35 +0100
Mail-followup-to:, Jens Seidel <>
Original-recipient: rfc822;
Reply-to:, Jens Seidel <>
User-agent: Mutt/1.5.13 (2006-08-11)

I have a SGI Octane IP30 and was able to boot Linux on it with the
ip30-r10k+-20050128.img Gentoo kernel. Nevertheless I noticed that
this kernel is very unstable.

Once I was lucky and able to bootstrap Debian before the kernel paniced
again (usually a "unaligned instruction access in
arch/mips/kernel/unaligned.c::do_ade, line 544[#3]").

I tried to compile a newer 2.6.19-rc1 kernel and applied the two IOC3
and IP30 patches from First of all
the patch fails slightly and needs manual adjustments. Compiling results
in an error, do_IRQ() is called with only one parameter instead of two.

So I wonder what kernels are compatible with
linux-mips-2.6.19-rc1-ip30-r28.patch.bz2. Do I need other patches as
well? Also the kernel config file skylark-approved-config-tm in skylark/
is out of date. It seems to match a 2.6.12 or similar version.

PS: Please CC: me.


<Prev in Thread] Current Thread [Next in Thread>