linux-mips
[Top] [All Lists]

Re: upgrade toolchain(gcc-4.1)

To: ��� <barrioskmc@gmail.com>
Subject: Re: upgrade toolchain(gcc-4.1)
From: Ralf Baechle <ralf@linux-mips.org>
Date: Thu, 9 Nov 2006 12:08:11 +0000
Cc: linux-mips@linux-mips.org
In-reply-to: <000f01c703c3$de5d7000$45a6580a@swcenter.sec.samsung.co.kr>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <000f01c703c3$de5d7000$45a6580a@swcenter.sec.samsung.co.kr>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.4.2.2i
On Thu, Nov 09, 2006 at 02:56:55PM +0900, ������ wrote:
> From: ������ <barrioskmc@gmail.com>

> Hi all. 
> Currently I use gcc-3.4.4 in my mips board. 
> I want to update my toolchain(gcc, glibc, binutil etc.. ) to latest new
> toolchains( for example, gcc-4.1)
> But, in http://www.linux-mips.org/wiki/Toolchains, Roll-your-own is
> obsolete. Also, There isn't description about glibc. 

Updating glibc is a little non-trivial due to compatibility issues, extra
patches requires, version dependencies to the build environment and other
constraints so I deciede to drop the glibc documentation when I replaced
the old MIPS Howto document with the current size.

The good news are that the glibc world is getting somewhat simpler again
so maybe it's time to re-introduce some glibc documentation.

That said glibc will probably always stay somewhat non-trivial and most
people are probably best off by just using binaries.

  Ralf

<Prev in Thread] Current Thread [Next in Thread>