Russell King wrote:
@@ -576,22 +626,17 @@ static int size_fifo(struct uart_8250_po
static unsigned int autoconfig_read_divisor_id(struct uart_8250_port *p)
- unsigned char old_dll, old_dlm, old_lcr;
- unsigned int id;
+ unsigned char old_lcr;
+ unsigned int id, old_dl;
old_lcr = serial_inp(p, UART_LCR);
serial_outp(p, UART_LCR, UART_LCR_DLAB);
+ old_dl = _serial_dl_read(p);
- old_dll = serial_inp(p, UART_DLL);
- old_dlm = serial_inp(p, UART_DLM);
- serial_outp(p, UART_DLL, 0);
- serial_outp(p, UART_DLM, 0);
- id = serial_inp(p, UART_DLL) | serial_inp(p, UART_DLM) << 8;
+ serial_dl_write(p, 0);
+ id = serial_dl_read(p);
- serial_outp(p, UART_DLL, old_dll);
- serial_outp(p, UART_DLM, old_dlm);
+ serial_dl_write(p, old_dl);
serial_outp(p, UART_LCR, old_lcr);
Not sure the autoconfig code was intended for half-compatible UARTs.
Note that it sets up->port.type as its result. However, your change seems
correct, it just have nothing to do with RM9000.
It's worse than that - this code is there to read the ID from the divisor
registers implemented in some UARTs. If it isn't one of those UARTs, it's
expected to return zero.
Well, I guess it should still return 0 (or revision) if we use serial_dl_*()?
So we don't actually want to be prodding some other random registers on
As a side note, I think that the code that sets DLAB before and resets it
after the divisor latch read/write should be part of serial_dl_read() and
serial_dl_write() actually. In the Alchemy UARTs this bit is reserved.
Not really, for two reasons.
1. We end up with additional pointless writes to undo what serial_dl_*
2. setting DLAB might work for a subset of ports, but others require
different magic numbers written to LCR to access the divisor.
Indeed, I've spotted one such case. But we could possible RMW the line
control reg. so that serial_dl_*() "cleanup" after themselves?
3. other ports have additional properties when DLAB is set, to the
extent that you must not write other registers when it's reset to
avoid clearing some features you want to enable.
So, really, Moving that stuff into serial_dl_* ends up adding additional
code and complexity where it isn't needed.
Well, alternatively, the checks might be added to the places where DLAB is
written preventing the write for UARTs that don't have the bit. Or even such
check and LCR masking or even write skipping might be added to serial_out()?