linux-mips
[Top] [All Lists]

Re: [PATCH 1/7] Make get_frame_info() more readable.

To: vagabon.xyz@gmail.com
Subject: Re: [PATCH 1/7] Make get_frame_info() more readable.
From: Atsushi Nemoto <anemo@mba.ocn.ne.jp>
Date: Wed, 02 Aug 2006 00:02:49 +0900 (JST)
Cc: ralf@linux-mips.org, linux-mips@linux-mips.org
In-reply-to: <11544244383201-git-send-email-vagabon.xyz@gmail.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <11544244373398-git-send-email-vagabon.xyz@gmail.com> <11544244383201-git-send-email-vagabon.xyz@gmail.com>
Sender: linux-mips-bounce@linux-mips.org
On Tue,  1 Aug 2006 11:27:11 +0200, Franck Bui-Huu <vagabon.xyz@gmail.com> 
wrote:
> +static inline int is_ra_save_ins(union mips_instruction *pc)
> +{
> +     /* sw / sd $ra, offset($sp) */
> +     return (pc->i_format.opcode == sw_op || pc->i_format.opcode == sd_op) &&
> +             pc->i_format.rs == 29 &&
> +             pc->i_format.rt == 31;
> +}

Separating these function would be good, but let's play with 80
columns rule.

---
Atsushi Nemoto

<Prev in Thread] Current Thread [Next in Thread>