linux-mips
[Top] [All Lists]

Re: Ethernet bridging on 2.6.12-rc3 (PMC-sierra patched)

To: Roman Mashak <mrv@corecom.co.kr>
Subject: Re: Ethernet bridging on 2.6.12-rc3 (PMC-sierra patched)
From: Ralf Baechle <ralf@linux-mips.org>
Date: Mon, 19 Jun 2006 14:51:56 +0100
Cc: linux-mips@linux-mips.org
In-reply-to: <000601c6937f$0bed5270$9d0ba8c0@mrv>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <000601c6937f$0bed5270$9d0ba8c0@mrv>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.4.2.1i
On Mon, Jun 19, 2006 at 06:02:08PM +0900, Roman Mashak wrote:

> I was observing this strange problem today while verifying performance of 
> Sequoia board.
> 
> Initial conditions:
> 1) 2.6.12-rc3_L002 kernel from PMCS ftp, compiled for 32bit mode
> 2) bridge code is compiled into kernel
> 3) four 100Mbps ethernet devices and one onboard Gigabit link are joined 
> into bridge using bridge-utils-1.1
> 4) I connected board gigabit link to SmartBit Gb interface and four 100mbps 
> links to SmartBit FastEthernet interfaces
> 
> But 'brctl showmacs br0' shows only fast ethernet links being learned, but 
> never gigabit. We have suspicion that Titan driver affects this somehow.

The Titan driver (the version on linux-mips.org and any other version I've
seen) are pretty broken and remarkably ugly pieces of code.  The authors
of the Basler eXcite platform have contributed their driver and I hope it
will show up upstream soon.  Afaik it has not been tested with any of
PMC's eval boards but the necessary changes should not be hard.

  Ralf

<Prev in Thread] Current Thread [Next in Thread>