linux-mips
[Top] [All Lists]

Re: DECstation compile fails: opcode not supported (eret)

To: linux-mips@linux-mips.org
Subject: Re: DECstation compile fails: opcode not supported (eret)
From: Martin Michlmayr <tbm@cyrius.com>
Date: Sun, 22 Jan 2006 13:11:53 +0000
In-reply-to: <43D2F4D9.6010406@gentoo.org>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <20060121195956.GA15498@deprecation.cyrius.com> <43D2F4D9.6010406@gentoo.org>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.5.11
* Kumba <kumba@gentoo.org> [2006-01-21 21:58]:
> >  AS      arch/mips/kernel/genex.o
> >arch/mips/kernel/genex.S: Assembler messages:
> >arch/mips/kernel/genex.S:240: Error: opcode not supported on this 
> >processor: mips1 (mips1) `eret'
> >make[1]: *** [arch/mips/kernel/genex.o] Error 1
> >make: *** [arch/mips/kernel] Error 2
> >
> >Toolchain used:
> >gcc version 4.0.3 20051201 (prerelease) (Debian 4.0.2-5)
> >binutils: 2.16.91 20051117 Debian GNU/Linux
> 
> I think this broke it:

That's right, reverting Ralf's commit
  Remove stray .set mips3 resulting in 64-bit instruction in 32-bit kernels.
makes it compile.

-- 
Martin Michlmayr
http://www.cyrius.com/

<Prev in Thread] Current Thread [Next in Thread>