linux-mips
[Top] [All Lists]

Re: Bus error on sb1250

To: linux-mips@linux-mips.org
Subject: Re: Bus error on sb1250
From: Peter 'p2' De Schrijver <p2@debian.org>
Date: Sun, 25 Sep 2005 15:45:38 +0200
In-reply-to: <20050924215710.GA6310@codecarver>
Mail-followup-to: peter.de.schrijver@mind.be, linux-mips@linux-mips.org
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <20050924215710.GA6310@codecarver>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.5.6+20040907i
Hi,

On Sat, Sep 24, 2005 at 11:57:10PM +0200, Peter 'p2' De Schrijver wrote:
> Hi,
> 
> I'm seeing some strange bus errors when trying to get the Fore
> ForeRunner PCA-200EPC card to work on the sibyte swarm. The driver polls
> a register on this card for status information. This triggers a bus
> error once in a while. This happens regardless if the card is attached
> to the PCI bus of the sb1250 or to the PCI bus behind the Alliance HT -
> PCI bridge. 
> 

Thanks to Maciej, I found the problem. The device apparently does not
always react in time for the sb1250 PCI host. Changing TrdyTimeout to
0xff fixes the problem for the 32bit PCI slots. I need to find the
equivalent register on the SP1011 bridge to fix the problem for the
64bit PCI slots. Patch attached.

Cheers,

Peter (p2).

--
goa is a state of mind

Attachment: patch-pci
Description: Text document

Attachment: signature.asc
Description: Digital signature

<Prev in Thread] Current Thread [Next in Thread>
  • Bus error on sb1250, Peter 'p2' De Schrijver
    • Re: Bus error on sb1250, Peter 'p2' De Schrijver <=