linux-mips
[Top] [All Lists]

Re: NPTL info needed

To: mohanlal jangir <mohanlaljangir@hotmail.com>
Subject: Re: NPTL info needed
From: "Steven J. Hill" <sjhill@realitydiluted.com>
Date: Sun, 21 Aug 2005 14:34:53 -0500
Cc: linux-mips@linux-mips.org
In-reply-to: <BAY18-DAV2A05369EA8C7D91990C16D2B50@phx.gbl>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <200508181804.LAA04568@mon-irva-10.broadcom.com> <4304D201.2060306@mvista.com> <BAY18-DAV2A05369EA8C7D91990C16D2B50@phx.gbl>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Debian Thunderbird 1.0.6 (X11/20050802)
mohanlal jangir wrote:

Thanks for your help. I tried to apply this patch on Linux-2.6.10 and many hunks failed. Could you tell me which kernel version this patch should be applied? Also do I need to apply any patch to gcc, glibc sources (and build a new toolchain)?

Mohanlal,

If you are wanting to work with NPTL and MIPS, please use the latest
Linux version from the Linux/MIPS cvs tree. The latest releases of
binutils-2.16.x contain NPTL support for MIPS. You will need to use
the HEAD of gcc cvs and the HEAD of glibc cvs in order to get the
MIPS NPTL support. Please note that NO backport of NPTL will be done
to versions of GCC older than 4.1.0. Have fun.

-Steve

<Prev in Thread] Current Thread [Next in Thread>