linux-mips
[Top] [All Lists]

Re: reboot gets stuck in a TLB exception on Au1550 based board

To: Clem Taylor <clem.taylor@gmail.com>
Subject: Re: reboot gets stuck in a TLB exception on Au1550 based board
From: Dan Malek <dan@embeddedalley.com>
Date: Tue, 12 Jul 2005 17:46:44 -0700
Cc: linux-mips@linux-mips.org
In-reply-to: <ecb4efd105071217254e68b9e2@mail.gmail.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <ecb4efd105071217254e68b9e2@mail.gmail.com>
Sender: linux-mips-bounce@linux-mips.org

On Jul 12, 2005, at 5:25 PM, Clem Taylor wrote:

I was wondering if anyone else has a problem with reboot not working
on a Au1550?

What kernel and what version of YAMON?

I just happened to have a shell prompt on the Au1550 with 2.4.31
and YAMON ROM Monitor, Revision 02.24DB1550.

Reboot worked just fine, got me back to the YAMON prompt and
booted Linux.

 When I issue a reboot, the kernel prints "** Resetting
Integrated Peripherals", but the system doesn't reboot.

Do you know what peripherals may have been running
when you did the reboot?  I was using an NFS root file system
and had AC97 audio running.

My BDI shows ....

What happens if you don't have the BDI connected?  Often,
boot roms step on debugger set up that the BDI does, causing
confusion on both parties.

One difference between the stock db1x00 code and my code ....

Oh, now you tell me :-)  Custom hardware and different code,
I wonder why it doesn't work? :-)

It seems that if the hardware, YAMON, and Linux are all compatible,
there isn't any trouble.  Yes, I was using the Db1550.

I was wondering if anyone might have a clue what is going on or some
suggestions on what I can do to continue debugging this?

Only you know what is different, so you may want to look in those
places first.

Have fun!

        -- Dan


<Prev in Thread] Current Thread [Next in Thread>