linux-mips
[Top] [All Lists]

Re: Seg fault when compiled with -mabi=64 and -lpthread

To: Ralf Baechle <ralf@linux-mips.org>
Subject: Re: Seg fault when compiled with -mabi=64 and -lpthread
From: Daniel Jacobowitz <dan@debian.org>
Date: Thu, 30 Jun 2005 17:03:58 -0400
Cc: Bryan Althouse <bryan.althouse@3phoenix.com>, 'Linux/MIPS Development' <linux-mips@linux-mips.org>
In-reply-to: <20050630202111.GC3245@linux-mips.org>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <20050630173409Z8226102-3678+735@linux-mips.org> <20050630202111.GC3245@linux-mips.org>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.5.8i
On Thu, Jun 30, 2005 at 09:21:11PM +0100, Ralf Baechle wrote:
> On Thu, Jun 30, 2005 at 01:33:39PM -0400, Bryan Althouse wrote:
> 
> > The executable will seg fault.  If I remove the -lpthread, it is fine.
> > Also, if I change the 64 to 32, it is fine.
> 
> I fear you may be hitting these problems simple because you're the first
> through the mine field of 64-bit pthreads ;-)  So far most people are
> simple running 32-bit software on their 64-bit kernels.  No reason to
> panic though, most of the bits are in place, it's just the one or other
> insect hiding in the code.

Bryan seems to be using the original Red Hat gnupro 64-bit toolchain. 
I don't know how well that works nowadays; but current CVS versions do
work, or did when I last tested (a month or two ago).

-- 
Daniel Jacobowitz
CodeSourcery, LLC

<Prev in Thread] Current Thread [Next in Thread>