linux-mips
[Top] [All Lists]

Re: Newbie : Cross-compiling module for wrt54g

To: Christophe Jelger <Christophe.Jelger@unibas.ch>
Subject: Re: Newbie : Cross-compiling module for wrt54g
From: JP <jaypee@hotpop.com>
Date: Thu, 03 Mar 2005 16:29:04 +0000
Cc: linux-mips@linux-mips.org
In-reply-to: <42272589.7000802@unibas.ch>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <42272589.7000802@unibas.ch>
Sender: linux-mips-bounce@linux-mips.org
Christophe

> The issues I have are : tools to use, kernel-header files versions 
> (wrt54g uses 2.4.20, means do I have to compile on a 2.4.20 machine ?), 
> debugging on wrt54g (can I use standard log-file ?).

You'll need the header files that linksys used which may or may not be
different to the 2.4.10 vanilla kernel headers

for the wrt54g you can get the right code for your FW rev here.
http://www.linksys.com/support/gpl.asp

Here's a page about tools
http://www.linux-mips.org/wiki/index.php/Toolchains

You might need an older toolchain to build 2.4 kernels.
Anyone have any success on build 2.4.x with gcc 3.x?

Don't take my word for it though I've been using a recentish gcc-3.4.1
built using uclibc's buildroot to build 
It was pretty easy to get working and install.

For our 2.4 kernels I used a montavista toolchain for the last few
years. mvista.com requires you register.

Happy hacking

-- 
JP <jaypee@hotpop.com>



<Prev in Thread] Current Thread [Next in Thread>