linux-mips
[Top] [All Lists]

Re: PCMCIA VR4131

To: suresh@mistralsoftware.com
Subject: Re: PCMCIA VR4131
From: Yoichi Yuasa <yuasa@hh.iij4u.or.jp>
Date: Tue, 15 Jun 2004 23:00:56 +0900
Cc: linux-mips@linux-mips.org
In-reply-to: <1087299491.2974.8.camel@sarge>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1087299491.2974.8.camel@sarge>
Sender: linux-mips-bounce@linux-mips.org
Hi

On Tue, 15 Jun 2004 17:08:12 +0530
"Suresh. R" <suresh@mistralsoftware.com> wrote:

> Hi,
>   I am modifying the PCMCIA driver (linux 2.4.18 for mips) to make it
> work it with the Richo controller(RF5C296). I made some hack and now the
> driver is able to detect the type of controller and also the cardmgr is
> detecting the type of the card plugged in properly(and properly
> inserting the module for that card). But then (I am right now just
> trying to make the CF storage card work with the kernel) when I load all
> the modules and then run cardmgr and insert the card, I am getting the
> following message. 
> 
> ide0: ports already in use, skipping probe
> 
> This messages keeps repeating for some time and then it stops saying the
> resource is busy.

What did you set ioport range in your config.opts?

> The pcmcia driver is right now working in the polling mode. Please help
> me, if someone has done it before. I just modified the MEM base and IO
> base and now outb and inb are reading from that location. So I think the
> CIS is being read properly. What could be wrong ?.

Yoichi

<Prev in Thread] Current Thread [Next in Thread>