On Thu, 29 Apr 2004, Tim Bird wrote:
> I'm looking at some sources for kernel Execute-in-place (XIP).
> I see references to CONFIG_XIP_ROM and CONFIG_XIP_KERNEL,
> in different architecture branches of the same kernel
> source tree.
> Is this difference merely the result of inconsistent
> usage, or is there a functional difference between
> these two options?
It's the result of me deciding CONFIG_XIP_ROM wasn't totally appropriate ...
> I can imagine that CONFIG_XIP_ROM is intended only to
> handle XIP in ROM, and that CONFIG_XIP_KERNEL possibly
> handles additional cases like XIP in flash. However,
> before jumping to that conclusion I thought I would
> ask if there is some intention behind the different
> config names.
... so I renamed it to CONFIG_XIP_KERNEL. Especially since there is also
XIPable user space which also can be stored in ROM (or flash). So please
disregard CONFIG_XIP_ROM and use CONFIG_XIP_KERNEL. Whether ROM or Flash is
used is rather irrelevant to the code this option is linked to.