linux-mips
[Top] [All Lists]

Re: LK201 keyboard

To: linux-mips@linux-mips.org
Subject: Re: LK201 keyboard
From: Jan-Benedict Glaw <jbglaw@lug-owl.de>
Date: Tue, 21 Oct 2003 22:23:28 +0200
In-reply-to: <Pine.GSO.3.96.1031021152207.23366D-100000@delta.ds2.pg.gda.pl>
Mail-followup-to: linux-mips@linux-mips.org
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <20031021131033.GM20846@lug-owl.de> <Pine.GSO.3.96.1031021152207.23366D-100000@delta.ds2.pg.gda.pl>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.5.4i
On Tue, 2003-10-21 15:51:21 +0200, Maciej W. Rozycki <macro@ds2.pg.gda.pl>
wrote in message 
<Pine.GSO.3.96.1031021152207.23366D-100000@delta.ds2.pg.gda.pl>:
> > However, the "Set Mode" command (to set the repeat mode for a block of
> > keys) doesn't work for me on a lk201. Using a lk401 instead, these
> > commands work. Every time I send a set-mode command, I get a Input Error
> > (from the keyboard) sent back...
> 
>  Strange -- these work for me.

What the "old" lk driver uses is more-or-less what could be referred as
power-on configuration. Even if there are set mode commande - if they
were ignored, it would silently work as expected. Could you set all
groups to "DOWN_UP_MODE" and verify that it no longer works?

MfG, JBG

-- 
   Jan-Benedict Glaw       jbglaw@lug-owl.de    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));

Attachment: pgpJ7t4tfFXij.pgp
Description: PGP signature

<Prev in Thread] Current Thread [Next in Thread>