linux-mips
[Top] [All Lists]

Re: LK201 keyboard

To: Jan-Benedict Glaw <jbglaw@lug-owl.de>
Subject: Re: LK201 keyboard
From: "Maciej W. Rozycki" <macro@ds2.pg.gda.pl>
Date: Tue, 21 Oct 2003 15:51:21 +0200 (MET DST)
Cc: linux-mips@linux-mips.org
In-reply-to: <20031021131033.GM20846@lug-owl.de>
Organization: Technical University of Gdansk
Original-recipient: rfc822;linux-mips@linux-mips.org
Sender: linux-mips-bounce@linux-mips.org
On Tue, 21 Oct 2003, Jan-Benedict Glaw wrote:

> I'm currently reworking the LK201 keyboard driver to attach it to the
> new Input API, as well as letting it use the serio interface (-> this
> way, you're not bound to dz.c/zs.c).

 Thanks for your effort and please cooperate -- I have some have
half-baked patches for the driver to let it pass native codes for the raw 
mode as appropriate.

> I've got a little problem with it, though. I've got docs (for the VAX)
> which describe the LK201 in detail. First of all, the "Set LEDs On"
> command is wrong there (advertised as 0x12, but 0x13 actually works;
> this is what the current driver uses, too). That may be a typo, though..

 This is definitely a typo -- 0x12 is a Set Mode command (mode: 1, key
group: 2; a repeat register number follows).  The definitions in lk201.h
have been verified to be correct.

> However, the "Set Mode" command (to set the repeat mode for a block of
> keys) doesn't work for me on a lk201. Using a lk401 instead, these
> commands work. Every time I send a set-mode command, I get a Input Error
> (from the keyboard) sent back...

 Strange -- these work for me.

> I'd like to ask you DECstation users to verify that the set-mode command
> actually works for you on a lk201... Or do you all use the newer lk401?

 I have an LK201 and the current code was tested almost exclusively with
it.

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: macro@ds2.pg.gda.pl, PGP key available        +


<Prev in Thread] Current Thread [Next in Thread>