linux-mips
[Top] [All Lists]

Re: udelay

To: linux-mips@linux-mips.org
Subject: Re: udelay
From: Kumba <kumba@gentoo.org>
Date: Fri, 01 Aug 2003 22:42:41 -0400
In-reply-to: <1059788948.9224.62.camel@zeus.mvista.com>
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <1059788948.9224.62.camel@zeus.mvista.com>
Reply-to: kumba@gentoo.org
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Pete Popov wrote:

Looks like the latest udelay in 2.4 is borked. Anyway else notice that
problem?  I did a 10 sec test: mdelay works, udelay is broken, at least
for the CPU and toolchain I'm using.

Pete

What's one way of testing this brokeness? I've been trying to find some explanation for a bug of some sort in a cobalt RaQ2 in which the tulip driver (eth0) just stops dead after several minutes of use. One of the notable features of the tulip driver patch needed to work on the RaQ2 adds a "udelay(1000)" into the tulip source. Without it, the eth0 on the RaQ2 is dead, so I wonder if these are related.

If they are related, then this behavior has been slowly getting worse it seems, as eth0 on the RaQ2 apparently has had smaller and smaller amounts of time needed before the interface died. 2.4.18, it took most of a day, by 2.4.21, it happens within seconds.

--Kumba

--
"Such is oft the course of deeds that move the wheels of the world: small hands do them because they must, while the eyes of the great are elsewhere." --Elrond


<Prev in Thread] Current Thread [Next in Thread>