linux-mips
[Top] [All Lists]

Re: NFS Root broken in 2.4.18? Anyone successfully booted?

To: "TWEDE,ROGER (HP-Boise,ex1)" <roger_twede@hp.com>
Subject: Re: NFS Root broken in 2.4.18? Anyone successfully booted?
From: "H. J. Lu" <hjl@lucon.org>
Date: Thu, 31 Oct 2002 11:44:49 -0800
Cc: 'Ralf Baechle' <ralf@linux-mips.org>, "'linux-mips@linux-mips.org'" <linux-mips@linux-mips.org>
In-reply-to: <CBD6266EA291D5118144009027AA63350A68F183@xboi05.boi.hp.com>; from roger_twede@hp.com on Thu, Oct 31, 2002 at 01:28:05PM -0500
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <CBD6266EA291D5118144009027AA63350A68F183@xboi05.boi.hp.com>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.2.5.1i
On Thu, Oct 31, 2002 at 01:28:05PM -0500, TWEDE,ROGER (HP-Boise,ex1) wrote:
> Ralf et al,
> 
> I found that the 2.4.18 system boots fine when booting from standard devices
> (IDE disks etc.).
> 
> Init fails to execute successfully when booting from NFS.  The NFS booting
> success appears to have died with 2.4.18.
> 
> The NFS boot completes fine in 2.4.17 but in 2.4.18 the NFS root is mounted
> and /sbin/init and the ld.so.1 are at least accessed, but the system never
> executes far enough in user space to even print a message to the console.
> 
> I've tried two different network card types just to be sure it wasn't a
> single driver issue.
> 
> Has anyone noticed this or does anyone know what changes may have caused
> this in 2.4.18? 
> I'm curious whether anyone has successfully booted 2.4.18 over NFS.
> 

Works fine with 2.4.20-pre6 in CVS.


H.J.

<Prev in Thread] Current Thread [Next in Thread>