linux-mips
[Top] [All Lists]

Re: Recent Kernel Page Fault Problems Spawning Init?

To: "TWEDE,ROGER (HP-Boise,ex1)" <roger_twede@hp.com>
Subject: Re: Recent Kernel Page Fault Problems Spawning Init?
From: Ralf Baechle <ralf@linux-mips.org>
Date: Wed, 30 Oct 2002 16:06:04 +0100
Cc: "'linux-mips@linux-mips.org'" <linux-mips@linux-mips.org>
In-reply-to: <CBD6266EA291D5118144009027AA63353F9412@xboi05.boi.hp.com>; from roger_twede@hp.com on Tue, Oct 29, 2002 at 05:53:15PM -0500
Original-recipient: rfc822;linux-mips@linux-mips.org
References: <CBD6266EA291D5118144009027AA63353F9412@xboi05.boi.hp.com>
Sender: linux-mips-bounce@linux-mips.org
User-agent: Mutt/1.2.5.1i
On Tue, Oct 29, 2002 at 05:53:15PM -0500, TWEDE,ROGER (HP-Boise,ex1) wrote:

> I would be appreciative of any advice anyone can offer in this regard.
> 
> Were any fundamental kernel changes made in the 2.4.17 through 2.4.19
> timeframe which could explain why the spawning of init would hang?
> 
> After mounting a root filesystem and attempting to spawn init, 3 or 4 page
> faults occur.  The entry point of init, its bss section and an elf loader
> .text section get hit, etc.  followed by an endless series of page faults to
> a bad address which just faults repeatedly, never allowing init or the elf
> loader to proceed.
> 
> I've tried a RM 7000A and 20KC based boards so far with apparently identical
> behavior on both.

Various people have reported this kind of problem in past but so far all of
them turned out some local problem.  20kc and RM7000 are both supposed to be
working fine.

  Ralf

<Prev in Thread] Current Thread [Next in Thread>