linux-mips
[Top] [All Lists]

Re: [2.4 PATCH] pcnet32.c - tx underflow error

To: Marcelo Tosatti <marcelo@conectiva.com.br>
Subject: Re: [2.4 PATCH] pcnet32.c - tx underflow error
From: Jun Sun <jsun@mvista.com>
Date: Fri, 12 Jul 2002 11:26:09 -0700
Cc: Alan Cox <alan@lxorguk.ukuu.org.uk>, linux-mips@oss.sgi.com, Ralf Baechle <ralf@oss.sgi.com>, Jeff Garzik <jgarzik@mandrakesoft.com>
References: <Pine.LNX.4.44.0207112350440.21590-100000@freak.distro.conectiva>
Sender: owner-linux-mips@oss.sgi.com
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901
Marcelo Tosatti wrote:


On Thu, 11 Jul 2002, Alan Cox wrote:


This patch fixes a tx underflow error for 79c973 chip.  It essentially delay
the transmission until the whole packet is received into the on-chip sdram.

The patch is already accepted by Marcelo for the 2.4 tree, I think.

Which slows the stuff down for people with real computers. Please apply
some kind of heuristic to this - eg switch to delaying if you exceed
50 failures in a 60 second period.


I haven't applied it yet.

I'll let it come to me throught Jeff Garzik after the issues are resolved.



Like I said earlier, I don't believe the benefit of run-time approach is worth the effort. BTW, the heuristic method is not simple, mainly because there are mixed bags of chips in this family which requires different handling in this regard.

Since Alan seems to oppose this patch, I will fix this problem for now in the board code/firmware, which is not a totally unreasonable solution anyway. After all the firmware knows this board bus cannot handle 100Mb/s net. If more people report the same problem later, that might be a better time to how to solve this problem.


Jun


<Prev in Thread] Current Thread [Next in Thread>