linux-mips
[Top] [All Lists]

Re: Continued MIPS kernel debugging symbols problem...

To: "Steven J. Hill" <sjhill@cotw.com>
Subject: Re: Continued MIPS kernel debugging symbols problem...
From: Daniel Jacobowitz <dan@debian.org>
Date: Fri, 14 Sep 2001 00:28:27 -0400
Cc: binutils@sources.redhat.com, gdb@sourceware.cygnus.com, linux-mips@oss.sgi.com
In-reply-to: <3BA16CAA.6B4DF4A1@cotw.com>; from sjhill@cotw.com on Thu, Sep 13, 2001 at 09:34:18PM -0500
Mail-followup-to: "Steven J. Hill" <sjhill@cotw.com>, binutils@sources.redhat.com, gdb@sourceware.cygnus.com, linux-mips@oss.sgi.com
References: <3BA16CAA.6B4DF4A1@cotw.com>
Sender: owner-linux-mips@oss.sgi.com
User-agent: Mutt/1.3.16i
On Thu, Sep 13, 2001 at 09:34:18PM -0500, Steven J. Hill wrote:
>     configure --prefix=/opt/tools --target=mipsel-linux-elf
> 
> since my target is a NEC 5432 running in LE mode. I had
> also tried 'mips-linux-elf' targets earlier in the day
> with no difference. I am still getting the following
> mismatch in symbols:

(Could you try building a mipsel-unknown-linux-gnu debugger/compiler
instead?  Does it make any difference?  I don't expect it to.)

> I compiled my kernel with a toolchain that used the following
> versions of tools:
> 
>     binutils-2.11.90.0.31 (HJLu patches applied)
>     gcc-3.0.1 (stock)
>     glibc-2.2.3 (minor build patches)

If you'll post a binary that you're having trouble debugging, I'll try
to find time in the next couple of days to see what GDB is doing wrong.

-- 
Daniel Jacobowitz                           Carnegie Mellon University
MontaVista Software                         Debian GNU/Linux Developer

<Prev in Thread] Current Thread [Next in Thread>