linux-mips
[Top] [All Lists]

RE: How to install the cross-compiler toolchain?

To: "'linux-mips@oss.sgi.com'" <linux-mips@oss.sgi.com>
Subject: RE: How to install the cross-compiler toolchain?
From: Phil Thompson <Phil.Thompson@pace.co.uk>
Date: Wed, 5 Sep 2001 11:17:04 +0100
Sender: owner-linux-mips@oss.sgi.com
Have you tried giving all the packages on the same command line?

        rpm -U glibc-*

...works for me.

Phil

> -----Original Message-----
> From: kjlin [mailto:kj.lin@viditec-netmedia.com.tw]
> Sent: 05 September 2001 10:51
> To: Jean-Christophe ARNU
> Cc: linux-mips@oss.sgi.com
> Subject: Re: How to install the cross-compiler toolchain?
> 
> 
> 
> ----- Original Message -----
> Subject: Re: How to install the cross-compiler toolchain?
> 
> 
> > On 05 Sep 2001 12:52:13 +0800, kjlin wrote:
> > > #rpm -ivh glibc-2.2.3-13.3.i386.rpm
> > > error: failed dependencies:
> > >                 glibc-common = 2.2.3-13.3 is needed by 
> glibc-2.2.3-13.3
> > >                 glibc-devel < 2.2.3 conflicts with 
> glibc-2.2.3-13.3
> > > I also tried to install glibc-common-2.2.3-13.3.i386.rpm but still
> failed.
> > > #rpm -ivh glibc-common-2.2.3-13.3.i386.rpm
> > > error: failed dependencies:
> > >                 glibc < 2.2.3 conflicts with 
> glibc-common-2.2.3-13.3
> > >
> > > I am confused by the result.
> >
> > You should update and not install glibc.
> > # rpm -uvh glibc-common-2.2.3-13.3.i386.rpm
> 
> It is the same.
> Just more error messages.
> # rpm -Uvh glibc-common-2.2.3-13.3.i386.rpm
> error: failed dependencies:
>         glibc < 2.2.3 conflicts with glibc-common-2.2.3-13.3
>         glibc-common = 2.2.2-10 is needed by glibc-2.2.2-10
> 
> # rpm -Uvh glibc-2.2.3-13.3.i386.rpm
> error: failed dependencies:
>         glibc-common = 2.2.3-13.3 is needed by glibc-2.2.3-13.3
>         glibc-devel < 2.2.3 conflicts with glibc-2.2.3-13.3
>         glibc > 2.2.2 conflicts with glibc-common-2.2.2-10
>         glibc = 2.2.2 is needed by glibc-devel-2.2.2-10
> 
> # rpm -Uvh glibc-devel-2.2.3-13.3.i386.rpm
> error: failed dependencies:
>         glibc = 2.2.3 is needed by glibc-devel-2.2.3-13.3
> 
> 
> 

<Prev in Thread] Current Thread [Next in Thread>