[Top] [All Lists]

Re: Re:/sbin/init problem in HH2.0 distro

To: "Kevin D. Kissell" <>
Subject: Re: Re:/sbin/init problem in HH2.0 distro
From: Fuxin Zhang <>
Date: Mon, 30 Jul 2001 22:37:14 +0800
Cc: "" <>
2001-07-30 16:17:00:
>Well, if you can run "passwd", can you run "nm"
>or some other utility to see if does
>in fact define the symbol _sec0?
Yes,I can. And there is no such symbol,so I suspect the disk drive first
>            Kevin K.
>----- Original Message -----
>From: "Fuxin Zhang" <>
>To: <>
>Sent: Monday, July 30, 2001 3:48 PM
>> hello,linux-mips
>>     I am porting support of Algorithmics P6032 evalution board from
>> 2.2 kernel to 2.4. I started with the kernel 2.4.3 from hardhat2.0
>> distribution.Now I am able to boot the kernel but it hangs up when
>> trying to exec /sbin/init.The error message is something like:
>>    Init: Kernel panic: trying to kill init
>>    Init:error loading, undefined symbol _sec0
>> But if i let the kernel execute /bin/ash.static directly,it can give me
>> a shell while complaining something like" no tty found,job control
>disabled". Then I can use most commands such as ls,passwd,cat.So the
>> can't be a corrupted one.
>>   The test environment is:
>>        Algorithmics P6032 with a idt79RC64474 CPU
>>        IDE hard disk(IBM Deskstar 40M,7200rpm)
>>   Kernel options:
>>        pci,ide(with/without dma,multimode) enabled
>>        serial console enabled
>>   What can be the cause?
>>   I suspect the ide driver first.But disabling dma doesn't help and it
>> seems to work quite well under ash.
>>   I am investigating the cause,if you want,I can provide more
>> information.
>> Regards
>>             Fuxin Zhang

            Fuxin Zhang

<Prev in Thread] Current Thread [Next in Thread>