linux-mips
[Top] [All Lists]

Re: glibc MIPS patch to check for binutils version...

To: "Steven J. Hill" <sjhill@cotw.com>
Subject: Re: glibc MIPS patch to check for binutils version...
From: "H . J . Lu" <hjl@lucon.org>
Date: Fri, 11 May 2001 08:54:15 -0700
Cc: libc-alpha@sources.redhat.com, linux-mips@oss.sgi.com
In-reply-to: <3AFBD5DE.A0457C6F@cotw.com>; from sjhill@cotw.com on Fri, May 11, 2001 at 07:06:54AM -0500
References: <3AFBD5DE.A0457C6F@cotw.com>
Sender: owner-linux-mips@oss.sgi.com
User-agent: Mutt/1.2.5i
On Fri, May 11, 2001 at 07:06:54AM -0500, Steven J. Hill wrote:
> ***** Changelog entry *****
>         * sysdeps/mips/rtld-ldscript.in: removed unneeded binary
>         output format directive

I don't believe those rtld-ldscript.in and rtld-parms are needed for
the new MIPS toolchain at all. They may cause more trouble than
without. Could you please tell me what breaks when you remove them?
There is a chance that the old binaries compiled against glibc 2.0.x
may run with the new glibc 2.2 without those linker scripts for the
IRIX ABI.


H.J.

<Prev in Thread] Current Thread [Next in Thread>