linux-mips
[Top] [All Lists]

Re: glibc MIPS patch to check for binutils version...

To: sjhill@cotw.com
Subject: Re: glibc MIPS patch to check for binutils version...
From: Andreas Jaeger <aj@suse.de>
Date: 11 May 2001 15:07:57 +0200
Cc: libc-alpha@sources.redhat.com, linux-mips@oss.sgi.com
In-reply-to: <3AFBD5DE.A0457C6F@cotw.com> ("Steven J. Hill"'s message of "Fri, 11 May 2001 07:06:54 -0500")
Mail-copies-to: never
References: <3AFBD5DE.A0457C6F@cotw.com>
Sender: owner-linux-mips@oss.sgi.com
User-agent: Gnus/5.090004 (Oort Gnus v0.04) XEmacs/21.1 (Channel Islands)
"Steven J. Hill" <sjhill@cotw.com> writes:

> Greetings.
> 
> Please find attached a patch to GLIBC that is compatible with
> the new version of binutils (HJLu's and CVS at least). I have
> also added some cruft in 'configure.in' that will produce
> warning messages if a user attempt to use old binutils. Comments
> are welcome. I have gone out on a limb and also included a
> Changelog entry in case this patch actually gets accepted :).
> This patch will apply against the CVS version of GLIBC. Please
> regenerate 'configure'. Thanks.
> 
> -Steve
> 
> 
> ***** Changelog entry *****
>         * sysdeps/mips/rtld-ldscript.in: removed unneeded binary
>         output format directive

Ok.


>         * configure.in: added in checking for obsolete binutils
>         for MIPS targets which produces a warning message if
>         user attempts to use older tools.
> ***************************

Let's do this differently.  I'm appending a patch that does it more
the "glibc way".  I've committed everything to CVS including a patch
for the FAQ.  I hope I got the version numbers right.

Thanks,
Andreas

2001-05-11  Andreas Jaeger  <aj@suse.de>

        * sysdeps/unix/sysv/linux/configure.in: Check binutils version on
        MIPS.

============================================================
Index: sysdeps/unix/sysv/linux/configure.in
--- sysdeps/unix/sysv/linux/configure.in        2001/03/16 07:35:59     1.37
+++ sysdeps/unix/sysv/linux/configure.in        2001/05/11 12:58:25
@@ -191,3 +191,14 @@
     AC_MSG_RESULT(ok)
   fi
 fi
+
+case "$machine" in
+  mips*)
+       AC_CHECK_PROG_VER(AS, $AS, --version,
+         [GNU assembler.* \([0-9]*\.[0-9.]*\(-ia64-[0-9]*\)*\)],
+         [2.11.90.0.[5-9]* | 2.11.90.[1-9]* | 2.11.9[1-9]* | 2.11.[1-9]* | 
2.1[2-9]*| 2.[2-9]*], 
+       AC_MSG_WARN([*** Your binutils versions are too old.  
+*** We strongly advise to update binutils.  For details check 
+*** the FAQ and INSTALL documents.]))
+       ;;
+esac
-- 
 Andreas Jaeger
  SuSE Labs aj@suse.de
   private aj@arthur.inka.de
    http://www.suse.de/~aj

<Prev in Thread] Current Thread [Next in Thread>