[Top] [All Lists]

Re: Binary compatibility break understood ?

To: "Steven J. Hill" <>
Subject: Re: Binary compatibility break understood ?
From: Ralf Baechle <>
Date: Wed, 9 May 2001 16:24:20 -0300
Cc: Andreas Jaeger <>, "Maciej W. Rozycki" <>, Florian Lohoff <>, Tom Appermont <>,
In-reply-to: <>; from on Wed, May 09, 2001 at 02:17:34PM -0500
References: <> <> <> <>
User-agent: Mutt/1.2.5i
On Wed, May 09, 2001 at 02:17:34PM -0500, Steven J. Hill wrote:

> > It's only modutils which for correct functionality depends on the trad-
> > format, so I don't see any real reason for raising version requirements
> > for libc.
> > 
> I can see your point...but...if we are trying fix the MIPS/Linux target
> from this point forward we should at least make people aware of what
> is going on. I propose spitting out a warning message when 'configure'
> is ran that if an older version of binutils/ld is found, then we warn
> the user that they may be unable to correctly use Linux kernel features
> or something like that. Comments?

These binutils break the kernel compilations, so we should check them as
part of kernel module compiles.


<Prev in Thread] Current Thread [Next in Thread>