linux-mips
[Top] [All Lists]

Re: Binary compatibility break understood ?

To: Ralf Baechle <ralf@oss.sgi.com>
Subject: Re: Binary compatibility break understood ?
From: "Steven J. Hill" <sjhill@cotw.com>
Date: Wed, 09 May 2001 14:17:34 -0500
Cc: Andreas Jaeger <aj@suse.de>, "Maciej W. Rozycki" <macro@ds2.pg.gda.pl>, Florian Lohoff <flo@rfc822.org>, Tom Appermont <tea@sonycom.com>, linux-mips@oss.sgi.com
References: <Pine.GSO.3.96.1010509144913.2489C-100000@delta.ds2.pg.gda.pl> <ho7kzqd5kb.fsf@gee.suse.de> <20010509150934.B2073@bacchus.dhis.org>
Reply-to: sjhill@cotw.com
Sender: owner-linux-mips@oss.sgi.com
Ralf Baechle wrote:
> 
> It's only modutils which for correct functionality depends on the trad-
> format, so I don't see any real reason for raising version requirements
> for libc.
> 
I can see your point...but...if we are trying fix the MIPS/Linux target
from this point forward we should at least make people aware of what
is going on. I propose spitting out a warning message when 'configure'
is ran that if an older version of binutils/ld is found, then we warn
the user that they may be unable to correctly use Linux kernel features
or something like that. Comments?

-Steve

-- 
 Steven J. Hill - Embedded SW Engineer
 Public Key: 'http://www.cotw.com/pubkey.txt'
 FPR1: E124 6E1C AF8E 7802 A815
 FPR2: 7D72 829C 3386 4C4A E17D

<Prev in Thread] Current Thread [Next in Thread>