linux-mips
[Top] [All Lists]

Re: Binary compatibility break understood ?

To: Andreas Jaeger <aj@suse.de>
Subject: Re: Binary compatibility break understood ?
From: "Steven J. Hill" <sjhill@cotw.com>
Date: Wed, 09 May 2001 08:59:24 -0500
Cc: Florian Lohoff <flo@rfc822.org>, Tom Appermont <tea@sonycom.com>, Ralf Baechle <ralf@oss.sgi.com>, linux-mips@oss.sgi.com
References: <20010505144708.A12575@paradigm.rfc822.org> <20010507163210.B2381@bacchus.dhis.org> <20010508202518.A13476@paradigm.rfc822.org> <20010508214313.A12528@bacchus.dhis.org> <20010509095955.A8392@sonycom.com> <20010509104635.D12267@paradigm.rfc822.org> <3AF934AE.38AB0089@cotw.com> <hoeltyemh0.fsf@gee.suse.de> <3AF93D3F.5E57070@cotw.com> <hopudid73g.fsf@gee.suse.de>
Reply-to: sjhill@cotw.com
Sender: owner-linux-mips@oss.sgi.com
Andreas Jaeger wrote:
> 
> > There's the patch. It's not much but it is correct. I have built multiple
> 
> But it's not complete.  AFAIK remember you posted a patch with some
> more changes and HJ even suggested to remove the rtld-ldscript.in file.
> 
I had this discussion with Ralf. He had reasons to not remove this
file altogether. Perhaps some input from him would be prudent. Ralf?!

> I need an update for the FAQ that explains which binutils version is
> required for MIPS and I prefer to have a test that checks on
> MIPS-Linux for the correct emulation in ld.
> 
As far as the versions for binutils:

   HJLu binutils-2.11.90.0.5 or greater
   CVS binutils
   binutils 2.11.1? (I'm not sure what the next release number is)

For the correct ld emulation, I assume you mean make changes in glibc
to check for the proper target 'elf[32|64]trad[little|big]mips'?

-Steve

-- 
 Steven J. Hill - Embedded SW Engineer
 Public Key: 'http://www.cotw.com/pubkey.txt'
 FPR1: E124 6E1C AF8E 7802 A815
 FPR2: 7D72 829C 3386 4C4A E17D

<Prev in Thread] Current Thread [Next in Thread>